Tag Archives: XenMobile

While using the ShareFile mobile applications, NTFS last modified date is updated each time a user accesses an NTFS connector

Here’ssharefile a weird little bug I caught in the wild while deploying XenMobile Enterprise. While browsing NTFS shares, published as connectors in the ShareFile Mobile clients, or the ShareFile desktop application for windows, all the directories in the directory you are currently browsing will have their “Last Modified” timestamp updated as below: sharefilebug Continue reading

XM

Cannot Log into XenMobile 10.3 Appliance after initial deployment.

XM<FYI, this was resolved in version 10.3.5>

Here’s a horrendous bug I just came across in the field today while deploying a XenMobile 10.3 Proof of Concept with a customer.

Post the initial deployment of the OVF on vSphere, i ran the usual CLI wizard to IP the appliance and create the database. After restart the web ‘Administrator’ user account just would not accept the password i provided during the wizard.

On closer inspection of the database by comparing with my own lab (never POC without a LAB!) , the ‘administrator’ username was completely missing from the database under ‘dbo.security_principal’…dbo.security_principal

what the ‘crappity crap’ went wrong I don’t know. but I reproduced it 4 times in numerous tests.

 

I managed to find a workaround involving specifying a different username. I.E. delete your deployment and database and when the wizard prompts for the ‘administrator’ name with default value, specify something different.

In my case I specified ‘zdmadmin’ and this worked correctly allowing me to get the hell out in time for a Friday beverage.

working

I hope this helps anyone else facing this issue!